Platform impaired. Database is overloaded

Incident Report for Osparc

Resolved

This incident has been resolved.
Posted Apr 02, 2025 - 13:01 UTC

Monitoring

A fix has been implemented and we are monitoring the results
Posted Apr 02, 2025 - 12:18 UTC

Update

We are continuing to work on a fix for this issue.
Posted Apr 02, 2025 - 12:05 UTC

Update

We have upgraded our database to a more powerful server machine. We are running tests and hope to get the platform operational soon. We will update this incident report in max 1 hour.
Posted Apr 02, 2025 - 12:05 UTC

Identified

We identified suboptimal SQL queries and are optimizing them.
Posted Apr 02, 2025 - 09:58 UTC

Investigating

Due to heavier-than-expected usage, the server that hosts our database is overloaded. We are working on mitigating the usage spike. Currently platform operations are impaired. We will provide an update on the incident in approx. 1 hour.
Posted Apr 02, 2025 - 09:41 UTC
This incident affected: Osparc.io.